summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-07-07 12:04:33 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-07-07 12:04:33 +0200
commit493d6a799be82a2df652b666d541a5e004ebcc76 (patch)
tree4d745d49abbde25f95cda0a7ebb59e81aabf7477 /tests/Makefile.am
parent37fd063042821dc328c88e1f7366543decdcb76f (diff)
downloadrsyslog-493d6a799be82a2df652b666d541a5e004ebcc76.tar.gz
rsyslog-493d6a799be82a2df652b666d541a5e004ebcc76.tar.xz
rsyslog-493d6a799be82a2df652b666d541a5e004ebcc76.zip
changed RainerScript testbench to a full-blow test suite
it now works based on test case files, which enable to quickly generate test cases.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d85a56f8..3ced4769 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,14 +1,15 @@
-check_PROGRAMS = rt_init rscript_parse
+check_PROGRAMS = rt_init rscript
TESTS = $(check_PROGRAMS)
test_files = testbench.h runtime-dummy.c
+EXTRA_DIST=*.rstest
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(rsrt_cflags)
rt_init_LDADD = $(rsrt_libs) $(zlib_libs) $(pthreads_libs)
rt_init_LDFLAGS = -export-dynamic
-rscript_parse_SOURCES = rscript-parse.c $(test_files)
-rscript_parse_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(rsrt_cflags)
-rscript_parse_LDADD = $(rsrt_libs) $(zlib_libs) $(pthreads_libs)
-rscript_parse_LDFLAGS = -export-dynamic
+rscript_SOURCES = rscript.c $(test_files)
+rscript_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(rsrt_cflags)
+rscript_LDADD = $(rsrt_libs) $(zlib_libs) $(pthreads_libs)
+rscript_LDFLAGS = -export-dynamic