summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-05-28 17:59:11 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-28 17:59:11 +0200
commit23dac82b684e966490de707a44144b3ad0ce2323 (patch)
tree1972593591da71c31badc1419866c882546048de /tests/Makefile.am
parentd8ba1a0d9f1f90c250cc2405f87be151ac609968 (diff)
downloadrsyslog-23dac82b684e966490de707a44144b3ad0ce2323.tar.gz
rsyslog-23dac82b684e966490de707a44144b3ad0ce2323.tar.xz
rsyslog-23dac82b684e966490de707a44144b3ad0ce2323.zip
small enhancement: config validation run now exits with code 1 if an error is detected.
This change is considered important but small enough to apply it directly to the stable version. [But it is a border case, the change requires more code than I had hoped. Thus I have NOT tried to actually catch all cases, this is left for the current devel releases, if necessary]
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 14e7c195..802a3ccb 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,10 +1,14 @@
check_PROGRAMS = rt_init rscript
-TESTS = $(check_PROGRAMS) cfg.sh
+TESTS = $(check_PROGRAMS) cfg.sh \
+ validation-run.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
#TESTS = $(check_PROGRAMS)
test_files = testbench.h runtime-dummy.c
EXTRA_DIST=1.rstest 2.rstest err1.rstest \
+ validation-run.sh \
+ testsuites/invalid.conf \
+ testsuites/valid.conf \
cfg.sh \
cfg1.cfgtest \
cfg1.testin \