summaryrefslogtreecommitdiffstats
path: root/plugins/omtesting/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-12-31 12:54:03 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-12-31 12:54:03 +0000
commitdd4dedbc38006e09e01ad1ed7f9790a5bc6fce59 (patch)
tree367a3ffef20c89b20a42e9af396564a0d5e7666d /plugins/omtesting/Makefile.am
parentf02c825c9518f576a4447152fd024726193a7dec (diff)
downloadrsyslog-dd4dedbc38006e09e01ad1ed7f9790a5bc6fce59.tar.gz
rsyslog-dd4dedbc38006e09e01ad1ed7f9790a5bc6fce59.tar.xz
rsyslog-dd4dedbc38006e09e01ad1ed7f9790a5bc6fce59.zip
created omtesting, a debug and development aid output module. This is stage
work for the new queueing engine - we need a way to delay rule execution and that's what the module currently does ;)
Diffstat (limited to 'plugins/omtesting/Makefile.am')
-rw-r--r--plugins/omtesting/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/plugins/omtesting/Makefile.am b/plugins/omtesting/Makefile.am
new file mode 100644
index 00000000..d7c9663b
--- /dev/null
+++ b/plugins/omtesting/Makefile.am
@@ -0,0 +1,6 @@
+pkglib_LTLIBRARIES = omtesting.la
+
+omtesting_la_SOURCES = omtesting.c omtesting.h ../../module-template.h
+omtesting_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../.. $(pthreads_cflags)
+omtesting_la_LDFLAGS = -module -avoid-version
+omtesting_la_LIBADD = $(mysql_libs)