summaryrefslogtreecommitdiffstats
path: root/plugins/ommysql/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-10-11 12:53:40 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-10-11 12:53:40 +0000
commit341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5 (patch)
tree749106882fa85e950b0257ac3084ac8c75aabcc2 /plugins/ommysql/Makefile.am
parent6e32d3f1dba30ac353d6bbdd93b7431eef6aa62d (diff)
downloadrsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.tar.gz
rsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.tar.xz
rsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.zip
- changed the build system to use a single source tarball again (but
different makefiles for the main project and ommysql) - applied fixes from Michael Biebl: 1.) fix failing compilation of ommysql plugin (s/ommysql-config.h/config.h/) 2.) fix mysql configure check (although the default is no, we did check for the mysql devel files) 3.) Create a separate Makefile.am for the doc files. This cleans up the toplevel Makefile.am considerably and makes it much more readable and maintainable. 3b) Assign the html doc files to html_DATA. This means, they are installed to $(hmtdir), which by autoconf standards is $(prefix)/share/doc/$packagename/. 4.) Reformat the SOURCES line to make it better readable and maintainable.
Diffstat (limited to 'plugins/ommysql/Makefile.am')
-rw-r--r--plugins/ommysql/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/plugins/ommysql/Makefile.am b/plugins/ommysql/Makefile.am
index 48987838..f388d1a9 100644
--- a/plugins/ommysql/Makefile.am
+++ b/plugins/ommysql/Makefile.am
@@ -1,9 +1,9 @@
pkglibdir = $(libdir)/rsyslog
pkglib_LTLIBRARIES = ommysql.la
-ommysql_la_SOURCES=ommysql.c ommysql.h
-ommysql_la_CPPFLAGS=$(mysql_cflags) -I$(srcdir)/../..
-ommysql_la_LDFLAGS=-module -avoid-version
-ommysql_la_LIBADD=$(mysql_libs)
+ommysql_la_SOURCES = ommysql.c ommysql.h
+ommysql_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../..
+ommysql_la_LDFLAGS = -module -avoid-version
+ommysql_la_LIBADD = $(mysql_libs)
EXTRA_DIST = createDB.sql contrib/delete_mysql