summaryrefslogtreecommitdiffstats
path: root/plugins/ommysql/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-09-26 10:24:14 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-09-26 10:24:14 +0000
commit88bbc402201c8bf088d310a9048bf38b77fb2f8e (patch)
treea35e8422723f8461360900f5d32539b8c368f267 /plugins/ommysql/Makefile.am
parent1c91a20427fe6af60bb385f695ce8768406fa194 (diff)
downloadrsyslog-88bbc402201c8bf088d310a9048bf38b77fb2f8e.tar.gz
rsyslog-88bbc402201c8bf088d310a9048bf38b77fb2f8e.tar.xz
rsyslog-88bbc402201c8bf088d310a9048bf38b77fb2f8e.zip
applied patch provided by varmojfekoj to support building ommysql in its
own way (now also resides in a plugin subdirectory)
Diffstat (limited to 'plugins/ommysql/Makefile.am')
-rw-r--r--plugins/ommysql/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/ommysql/Makefile.am b/plugins/ommysql/Makefile.am
new file mode 100644
index 00000000..48987838
--- /dev/null
+++ b/plugins/ommysql/Makefile.am
@@ -0,0 +1,9 @@
+pkglibdir = $(libdir)/rsyslog
+pkglib_LTLIBRARIES = ommysql.la
+
+ommysql_la_SOURCES=ommysql.c ommysql.h
+ommysql_la_CPPFLAGS=$(mysql_cflags) -I$(srcdir)/../..
+ommysql_la_LDFLAGS=-module -avoid-version
+ommysql_la_LIBADD=$(mysql_libs)
+
+EXTRA_DIST = createDB.sql contrib/delete_mysql