summaryrefslogtreecommitdiffstats
path: root/plugins/imuxsock/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-09-08 12:46:03 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-09-08 12:46:03 +0200
commit21a2672222a1b403ff0811154dec156676bed732 (patch)
tree982844283e04305132de3508e38d413c25a840cc /plugins/imuxsock/Makefile.am
parent3e2d011e8c1c42801194d387b75ca4f4a175ae5d (diff)
downloadrsyslog-21a2672222a1b403ff0811154dec156676bed732.tar.gz
rsyslog-21a2672222a1b403ff0811154dec156676bed732.tar.xz
rsyslog-21a2672222a1b403ff0811154dec156676bed732.zip
moved systemd interface to rsyslog convenience lib
Mostly a refresh of sd-daemon.[ch] from its source plus some make file changes. We now have systemd interfaces inside rsyslog, so that all plugins interested can call the interfaces. Seems not to be totally necessary right now, but will help in the long term.
Diffstat (limited to 'plugins/imuxsock/Makefile.am')
-rw-r--r--plugins/imuxsock/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/plugins/imuxsock/Makefile.am b/plugins/imuxsock/Makefile.am
index 8803937f..28f9f9e3 100644
--- a/plugins/imuxsock/Makefile.am
+++ b/plugins/imuxsock/Makefile.am
@@ -1,6 +1,6 @@
pkglib_LTLIBRARIES = imuxsock.la
-imuxsock_la_SOURCES = imuxsock.c ../../runtime/sd-daemon.c ../../runtime/sd-daemon.h
-imuxsock_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+imuxsock_la_SOURCES = imuxsock.c
+imuxsock_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
imuxsock_la_LDFLAGS = -module -avoid-version
-imuxsock_la_LIBADD =
+imuxsock_la_LIBADD = $(RSRT_LIBS)