summaryrefslogtreecommitdiffstats
path: root/plugins/imtcp/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-02-22 07:04:03 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-02-22 07:04:03 +0000
commit2c5712f6ac066d197d1255685368af93c9143c7d (patch)
tree5f2b05406c2b004e037b88d864d2d191275793b9 /plugins/imtcp/Makefile.am
parente45f50b55e2bcc64909d2a22698060a6eb6c2f5f (diff)
downloadrsyslog-2c5712f6ac066d197d1255685368af93c9143c7d.tar.gz
rsyslog-2c5712f6ac066d197d1255685368af93c9143c7d.tar.xz
rsyslog-2c5712f6ac066d197d1255685368af93c9143c7d.zip
integrated patch from Peter Vrabec to change the build process to produce
imtcp.so and imgssapi.so from imtcp.c (in support of new gassapi input module) - many thanks, Peter!
Diffstat (limited to 'plugins/imtcp/Makefile.am')
-rw-r--r--plugins/imtcp/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/plugins/imtcp/Makefile.am b/plugins/imtcp/Makefile.am
index fd06a1a0..fc4d00ae 100644
--- a/plugins/imtcp/Makefile.am
+++ b/plugins/imtcp/Makefile.am
@@ -1,6 +1,10 @@
-pkglib_LTLIBRARIES = imtcp.la
+pkglib_LTLIBRARIES = imtcp.la imgssapi.la
imtcp_la_SOURCES = imtcp.c
-imtcp_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(mudflap_cflags)
+imtcp_la_CPPFLAGS = -DFORCE_NO_GSS=1 -I$(top_srcdir) $(pthreads_cflags) $(mudflap_cflags)
imtcp_la_LDFLAGS = $(mudflap_libs) -module -avoid-version
-imtcp_la_LIBADD =
+
+imgssapi_la_SOURCES = imtcp.c
+imgssapi_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags) $(mudflap_cflags)
+imgssapi_la_LDFLAGS = $(mudflap_libs) -module -avoid-version
+imgssapi_la_LIBADD = $(gss_libs)