summaryrefslogtreecommitdiffstats
path: root/plugins/imklog/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-09 12:46:57 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-09 12:46:57 +0200
commitc565a7e847aeb58ddcd1bdbd006597953a4dea31 (patch)
treedc8a4bc89582ee4be48efff0291167cffa56fce4 /plugins/imklog/Makefile.am
parentd15985bc4065b4c65f491e6a829379687b2f52f1 (diff)
downloadrsyslog-c565a7e847aeb58ddcd1bdbd006597953a4dea31.tar.gz
rsyslog-c565a7e847aeb58ddcd1bdbd006597953a4dea31.tar.xz
rsyslog-c565a7e847aeb58ddcd1bdbd006597953a4dea31.zip
updated build system to detect correct klog driver
Diffstat (limited to 'plugins/imklog/Makefile.am')
-rw-r--r--plugins/imklog/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/plugins/imklog/Makefile.am b/plugins/imklog/Makefile.am
index 49bbbc70..946576fe 100644
--- a/plugins/imklog/Makefile.am
+++ b/plugins/imklog/Makefile.am
@@ -1,6 +1,15 @@
pkglib_LTLIBRARIES = imklog.la
-imklog_la_SOURCES = imklog.c linux.c imklog.h module.h ksym.c ksyms.h ksym_mod.c
+imklog_la_SOURCES = imklog.c imklog.h module.h ksym.c ksyms.h ksym_mod.c
+
+# select klog "driver"
+if ENABLE_IMKLOG_LINUX
+imklog_la_SOURCES += linux.c
+endif
+if ENABLE_IMKLOG_BSD
+imklog_la_SOURCES += bsd.c
+endif
+
imklog_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags)
imklog_la_LDFLAGS = -module -avoid-version
imklog_la_LIBADD =