summaryrefslogtreecommitdiffstats
path: root/plugins/imklog/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon>2008-04-09 09:00:13 +0200
committerRainer Gerhards <rgerhards@adiscon>2008-04-09 09:00:13 +0200
commitb0a4df43e4434a1eeb3f23c2c5a4b0cdd2fbddda (patch)
tree193d7759a8abb28b648845a63d98d9753b2765f7 /plugins/imklog/Makefile.am
parentc565a7e847aeb58ddcd1bdbd006597953a4dea31 (diff)
downloadrsyslog-b0a4df43e4434a1eeb3f23c2c5a4b0cdd2fbddda.tar.gz
rsyslog-b0a4df43e4434a1eeb3f23c2c5a4b0cdd2fbddda.tar.xz
rsyslog-b0a4df43e4434a1eeb3f23c2c5a4b0cdd2fbddda.zip
fixed build system for BSD
It's a hack, but at least it works now - on BSD. Will check later if it is fine on Linux, too. Any better method of doing things is happily accepted ;)
Diffstat (limited to 'plugins/imklog/Makefile.am')
-rw-r--r--plugins/imklog/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/plugins/imklog/Makefile.am b/plugins/imklog/Makefile.am
index 946576fe..511cd9be 100644
--- a/plugins/imklog/Makefile.am
+++ b/plugins/imklog/Makefile.am
@@ -1,13 +1,13 @@
pkglib_LTLIBRARIES = imklog.la
-imklog_la_SOURCES = imklog.c imklog.h module.h ksym.c ksyms.h ksym_mod.c
+imklog_la_SOURCES = imklog.c imklog.h
# select klog "driver"
-if ENABLE_IMKLOG_LINUX
-imklog_la_SOURCES += linux.c
-endif
if ENABLE_IMKLOG_BSD
imklog_la_SOURCES += bsd.c
+else
+# we assume this now is Linux (yes, some help with the build system is appreciated ;))
+imklog_la_SOURCES += linux.c module.h ksym.c ksyms.h ksym_mod.c
endif
imklog_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags)