summaryrefslogtreecommitdiffstats
path: root/plugins/imklog/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-08 23:34:14 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-08 23:34:14 +0200
commit838072a22f5a98e150dbab055eba28453238109f (patch)
tree1f0714ffa04a8e4c2912dfb1f4e45cbe8eb685ab /plugins/imklog/Makefile.am
parenta61f8543ff89a9eef1bef1686fff1035f5f79249 (diff)
downloadrsyslog-838072a22f5a98e150dbab055eba28453238109f.tar.gz
rsyslog-838072a22f5a98e150dbab055eba28453238109f.tar.xz
rsyslog-838072a22f5a98e150dbab055eba28453238109f.zip
changed imklog to a driver interface
imklog now uses os-specific drivers. The initial "set" contains the linux driver. This is a prequisite for BSD klog, which can now be implemented on that driver interface.
Diffstat (limited to 'plugins/imklog/Makefile.am')
-rw-r--r--plugins/imklog/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/imklog/Makefile.am b/plugins/imklog/Makefile.am
index 11e00962..49bbbc70 100644
--- a/plugins/imklog/Makefile.am
+++ b/plugins/imklog/Makefile.am
@@ -1,6 +1,6 @@
pkglib_LTLIBRARIES = imklog.la
-imklog_la_SOURCES = imklog.c imklog.h module.h ksym.c ksyms.h ksym_mod.c
+imklog_la_SOURCES = imklog.c linux.c imklog.h module.h ksym.c ksyms.h ksym_mod.c
imklog_la_CPPFLAGS = -I$(top_srcdir) $(pthreads_cflags)
imklog_la_LDFLAGS = -module -avoid-version
imklog_la_LIBADD =