summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-03-31 17:08:01 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2011-03-31 17:08:01 +0200
commitb30e809a202ef42e59a6c9e455e17ce56c7894bc (patch)
tree23e0584c2a0cc1fecdd7f2c9af69f7482e7c915b /configure.ac
parentb615cbaacec3d6f25e448362095ac54fcbe6d927 (diff)
parent945bc9bd0d9de984ab11b9faf609b809a1f3cb90 (diff)
downloadrsyslog-b30e809a202ef42e59a6c9e455e17ce56c7894bc.tar.gz
rsyslog-b30e809a202ef42e59a6c9e455e17ce56c7894bc.tar.xz
rsyslog-b30e809a202ef42e59a6c9e455e17ce56c7894bc.zip
Merge branch 'v5-devel'
Conflicts: configure.ac doc/manual.html doc/rsyslog_conf.html runtime/msg.c runtime/rsyslog.h template.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0de97cc..4a2e354a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1117,6 +1117,20 @@ AC_ARG_ENABLE(cust1,
AM_CONDITIONAL(ENABLE_CUST1, test x$enable_cust1 = xyes)
+# A custom strgen that also serves as a sample of how to do
+# SQL-generating strgen's
+AC_ARG_ENABLE(smcustbindcdr,
+ [AS_HELP_STRING([--enable-smcustbindcdr],[Compiles smcustbindcdr module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_smcustbindcdr="yes" ;;
+ no) enable_smcustbindcdr="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-smcustbindcdr) ;;
+ esac],
+ [enable_smcustbindcdr=no]
+)
+AM_CONDITIONAL(ENABLE_SMCUSTBINDCDR, test x$enable_smcustbindcdr = xyes)
+
+
# settings for the template input module; copy and modify this code
# if you intend to add your own module. Be sure to replace imtemplate
# by the actual name of your module.
@@ -1235,6 +1249,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omoracle/Makefile \
plugins/omudpspoof/Makefile \
plugins/mmnormalize/Makefile \
+ plugins/sm_cust_bindcdr/Makefile \
plugins/cust1/Makefile \
java/Makefile \
tests/Makefile])
@@ -1285,6 +1300,9 @@ echo
echo "---{ message modification modules }---"
echo " mmnormalize module will be compiled: $enable_mmnormalize"
echo
+echo "---{ strgen modules }---"
+echo " sm_cust_bindcdr module will be compiled: $enable_sm_cust_bindcdr"
+echo
echo "---{ database support }---"
echo " MySql support enabled: $enable_mysql"
echo " libdbi support enabled: $enable_libdbi"