summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:28:54 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:28:54 +0200
commit4f70113457993c536fc948d5b3b3e69dc7a92a8a (patch)
tree5682fe05ddeb53f20a28e02c3190185ce763cd8d /configure.ac
parent6e28d86c6a0a0c5788c5cb263b71aab19eb54cb5 (diff)
parentfe8ac119f75bc6d2763896b8e1a85ecfeb41bffb (diff)
downloadrsyslog-4f70113457993c536fc948d5b3b3e69dc7a92a8a.tar.gz
rsyslog-4f70113457993c536fc948d5b3b3e69dc7a92a8a.tar.xz
rsyslog-4f70113457993c536fc948d5b3b3e69dc7a92a8a.zip
Merge branch 'v5-stable' into v6-stable
Conflicts: ChangeLog configure.ac doc/manual.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed68a11c..3edc3223 100644
--- a/configure.ac
+++ b/configure.ac
@@ -518,8 +518,24 @@ if test "x$enable_mysql" = "xyes"; then
[AC_MSG_FAILURE([MySQL library is missing])],
[`mysql_config --libs`]
)
+ AC_MSG_CHECKING(if we have mysql_library_init)
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $MYSQL_CFLAGS"
+ save_LIBS="$LIBS"
+ LIBS="$LIBS $MYSQL_LIBS"
+ AC_TRY_LINK(
+ [#include <mysql.h>
+ #include <stdio.h>],
+ [mysql_library_init(0, NULL, NULL)],
+ [have_mysql_library_init=yes],
+ [have_mysql_library_init=no])
+ CFLAGS="$save_CFLAGS"
+ LIBS="$save_LIBS"
fi
AM_CONDITIONAL(ENABLE_MYSQL, test x$enable_mysql = xyes)
+if test "$have_mysql_library_init" = "yes"; then
+ AC_DEFINE([HAVE_MYSQL_LIBRARY_INIT], [1], [mysql_library_init available])
+fi
AC_SUBST(MYSQL_CFLAGS)
AC_SUBST(MYSQL_LIBS)