summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-12-07 11:33:06 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-12-07 11:33:06 +0000
commit320dfb91099df3dc5eddbef610ff04bcadfcfe2c (patch)
treea02ec86da7ef83489e457d4a2ace6346c4ed8e18 /configure.ac
parentc4cdfd526f8f8987d038706e6a854ff21c8f0e72 (diff)
downloadrsyslog-320dfb91099df3dc5eddbef610ff04bcadfcfe2c.tar.gz
rsyslog-320dfb91099df3dc5eddbef610ff04bcadfcfe2c.tar.xz
rsyslog-320dfb91099df3dc5eddbef610ff04bcadfcfe2c.zip
applied patch from Michael Biebl to finally fix the -ldl cross-platform
issue
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4212512a..570e77ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,10 +31,17 @@ esac
# Checks for libraries.
save_LIBS=$LIBS
-AC_SEARCH_LIBS(clock_gettime, rt, [rt_libs="-lrt" AC_SUBST(rt_libs)])
-AC_SEARCH_LIBS(dlopen, dl, [dl_libs="-ldl" AC_SUBST(dl_libs)])
+LIBS=
+AC_SEARCH_LIBS(clock_gettime, rt)
+rt_libs=$LIBS
+LIBS=
+AC_SEARCH_LIBS(dlopen, dl)
+dl_libs=$LIBS
LIBS=$save_LIBS
+AC_SUBST(rt_libs)
+AC_SUBST(dl_libs)
+
# Checks for header files.
AC_HEADER_RESOLV
AC_HEADER_STDC