summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:33:29 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:33:29 +0200
commite53ef769dd5eaf6399d2dfc467a29d9295aa1d73 (patch)
tree53d60d77fb1419ba0a497aca842f2f884d164efd /configure.ac
parent99d9c6d52ced294dee2822d36ede069c2bd37044 (diff)
parent4f70113457993c536fc948d5b3b3e69dc7a92a8a (diff)
downloadrsyslog-e53ef769dd5eaf6399d2dfc467a29d9295aa1d73.tar.gz
rsyslog-e53ef769dd5eaf6399d2dfc467a29d9295aa1d73.tar.xz
rsyslog-e53ef769dd5eaf6399d2dfc467a29d9295aa1d73.zip
Merge branch 'v6-stable'
Conflicts: tools/syslogd.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94d43d85..d92804f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,8 +517,24 @@ if test "x$enable_mysql" = "xyes"; then
[AC_MSG_FAILURE([MySQL library is missing])],
[`mysql_config --libs`]
)
+ AC_MSG_CHECKING(if we have mysql_library_init)
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $MYSQL_CFLAGS"
+ save_LIBS="$LIBS"
+ LIBS="$LIBS $MYSQL_LIBS"
+ AC_TRY_LINK(
+ [#include <mysql.h>
+ #include <stdio.h>],
+ [mysql_library_init(0, NULL, NULL)],
+ [have_mysql_library_init=yes],
+ [have_mysql_library_init=no])
+ CFLAGS="$save_CFLAGS"
+ LIBS="$save_LIBS"
fi
AM_CONDITIONAL(ENABLE_MYSQL, test x$enable_mysql = xyes)
+if test "$have_mysql_library_init" = "yes"; then
+ AC_DEFINE([HAVE_MYSQL_LIBRARY_INIT], [1], [mysql_library_init available])
+fi
AC_SUBST(MYSQL_CFLAGS)
AC_SUBST(MYSQL_LIBS)