summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-06-04 11:44:05 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2012-06-04 11:44:05 +0200
commitbac5b5abe4521c4265e493c897cb34996839d5d1 (patch)
treefc4bcf1942eb77d60626259291e4132a272fd0b5 /configure.ac
parent44f227b9594e95a4e2f223236b961cf533a50c12 (diff)
downloadrsyslog-c541519499e3372b647698436cdffe624a202ef2.tar.gz
rsyslog-c541519499e3372b647698436cdffe624a202ef2.tar.xz
rsyslog-c541519499e3372b647698436cdffe624a202ef2.zip
bugfix: made rsyslog compile when libestr ist not installed in /usrv6.3.10
Thanks to Miloslav Trmač for providing patches and suggestions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a35182fa..498b59d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -752,11 +752,15 @@ AC_ARG_ENABLE(rsyslogrt,
[enable_rsyslogrt=yes]
)
if test "x$enable_rsyslogrt" = "xyes"; then
- RSRT_CFLAGS="-I\$(top_srcdir)/runtime -I\$(top_srcdir) -I\$(top_srcdir)/grammar"
- RSRT_LIBS="\$(top_builddir)/runtime/librsyslog.la"
+ RSRT_CFLAGS1="-I\$(top_srcdir)/runtime -I\$(top_srcdir) -I\$(top_srcdir)/grammar"
+ RSRT_LIBS1="\$(top_builddir)/runtime/librsyslog.la"
#??CNF_LIBS="\$(top_builddir)/grammar/libgrammar.la"
fi
AM_CONDITIONAL(ENABLE_RSYSLOGRT, test x$enable_rsyslogrt = xyes)
+RSRT_CFLAGS="\$(RSRT_CFLAGS1) \$(LIBESTR_CFLAGS)"
+RSRT_LIBS="\$(RSRT_LIBS1) \$(LIBESTR_LIBS)"
+AC_SUBST(RSRT_CFLAGS1)
+AC_SUBST(RSRT_LIBS1)
AC_SUBST(RSRT_CFLAGS)
AC_SUBST(RSRT_LIBS)