summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:25:27 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2012-05-03 18:25:27 +0200
commitfdcaca6b85d65ef2c9b4814cc4a9adda4568e24f (patch)
tree21e07bd93a7bc45fd9b5b1084a88a0afae51e085 /configure.ac
parentfe50701280c9005d220d9c6eee78afc40fb59865 (diff)
parentfe8ac119f75bc6d2763896b8e1a85ecfeb41bffb (diff)
downloadrsyslog-fdcaca6b85d65ef2c9b4814cc4a9adda4568e24f.tar.gz
rsyslog-fdcaca6b85d65ef2c9b4814cc4a9adda4568e24f.tar.xz
rsyslog-fdcaca6b85d65ef2c9b4814cc4a9adda4568e24f.zip
Merge branch 'v5-stable' into v5-beta
Conflicts: ChangeLog configure.ac doc/manual.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e140b31..60cc7674 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,8 +517,24 @@ if test "x$enable_mysql" = "xyes"; then
[AC_MSG_FAILURE([MySQL library is missing])],
[`mysql_config --libs`]
)
+ AC_MSG_CHECKING(if we have mysql_library_init)
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $MYSQL_CFLAGS"
+ save_LIBS="$LIBS"
+ LIBS="$LIBS $MYSQL_LIBS"
+ AC_TRY_LINK(
+ [#include <mysql.h>
+ #include <stdio.h>],
+ [mysql_library_init(0, NULL, NULL)],
+ [have_mysql_library_init=yes],
+ [have_mysql_library_init=no])
+ CFLAGS="$save_CFLAGS"
+ LIBS="$save_LIBS"
fi
AM_CONDITIONAL(ENABLE_MYSQL, test x$enable_mysql = xyes)
+if test "$have_mysql_library_init" = "yes"; then
+ AC_DEFINE([HAVE_MYSQL_LIBRARY_INIT], [1], [mysql_library_init available])
+fi
AC_SUBST(MYSQL_CFLAGS)
AC_SUBST(MYSQL_LIBS)