summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-07-07 15:48:01 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-07-07 15:48:01 +0200
commitd4fe3d13894be957aeccbbc279854eacf9fd6f46 (patch)
treef4ca0d6656798d84b65b16a580e3dd33f0cc676f /configure.ac
parentb2418812cf06daf229e832cc212e65828e3c3417 (diff)
downloadrsyslog-d4fe3d13894be957aeccbbc279854eacf9fd6f46.tar.gz
rsyslog-d4fe3d13894be957aeccbbc279854eacf9fd6f46.tar.xz
rsyslog-d4fe3d13894be957aeccbbc279854eacf9fd6f46.zip
added new pm3164sd parser module
this permits to accept RFC5424 structured data from messages with RFC3164 header. This was compiled from existing modules by user izotov.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a25cfc0c..89a42aa3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -835,6 +835,18 @@ AC_ARG_ENABLE(omstdout,
)
AM_CONDITIONAL(ENABLE_OMSTDOUT, test x$enable_omstdout = xyes)
+# settings for pmrfc3164sd
+AC_ARG_ENABLE(pmrfc3164sd,
+ [AS_HELP_STRING([--enable-pmrfc3164sd],[Compiles rfc3164sd parser module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_pmrfc3164sd="yes" ;;
+ no) enable_pmrfc3164sd="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-pmrfc3164sd) ;;
+ esac],
+ [enable_pmrfc3164sd=no]
+)
+AM_CONDITIONAL(ENABLE_PMRFC3164SD, test x$enable_pmrfc3164sd = xyes)
+
# settings for omruleset
AC_ARG_ENABLE(omruleset,
@@ -953,6 +965,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omtemplate/Makefile \
plugins/omprog/Makefile \
plugins/omstdout/Makefile \
+ plugins/pmrfc3164sd/Makefile \
plugins/omruleset/Makefile \
plugins/omdbalerting/Makefile \
plugins/imfile/Makefile \
@@ -998,6 +1011,7 @@ echo "---{ output plugins }---"
echo " Mail support enabled: $enable_mail"
echo " omprog module will be compiled: $enable_omprog"
echo " omstdout module will be compiled: $enable_omstdout"
+echo " pmrfc3164sd module will be compiled: $enable_pmrfc3164sd"
echo " omruleset module will be compiled: $enable_omruleset"
echo " omdbalerting module will be compiled: $enable_omdbalerting"
echo " omudpspoof module will be compiled: $enable_omudpspoof"