summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-01-10 12:54:21 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2011-01-10 12:54:21 +0100
commitf7c20920046ebcb94eadadf1ebad97b634a12a2d (patch)
tree0cf704f462fa7394842beb3a496627915d863426 /configure.ac
parent58c486b36b27d30444b621876846052e239f8c50 (diff)
parent7742b2182fc017ca4c9fcfe3b26f4c8d68a9bd58 (diff)
downloadrsyslog-f7c20920046ebcb94eadadf1ebad97b634a12a2d.tar.gz
rsyslog-f7c20920046ebcb94eadadf1ebad97b634a12a2d.tar.xz
rsyslog-f7c20920046ebcb94eadadf1ebad97b634a12a2d.zip
Merge branch 'v5.6.2-newimudp' into v5-devel-newimudp
Conflicts: plugins/imudp/imudp.c threads.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b165afaa..e66e6a4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,6 +274,36 @@ if test "x$enable_pthreads" != "xno"; then
)
fi
+AC_CHECK_FUNCS(
+ [pthread_setschedparam],
+ [
+ rsyslog_have_pthread_setschedparam=yes
+ ],
+ [
+ rsyslog_have_pthread_setschedparam=no
+ ]
+)
+AC_CHECK_HEADERS(
+ [sched.h],
+ [
+ rsyslog_have_sched_h=yes
+ ],
+ [
+ rsyslog_have_sched_h=no
+ ]
+)
+if test "$rsyslog_have_pthread_setschedparam" = "yes" -a "$rsyslog_have_sched_h" = "yes"; then
+ save_LIBS=$LIBS
+ LIBS=
+ AC_SEARCH_LIBS(sched_get_priority_max, rt)
+ if test "x$ac_cv_search" != "xno"; then
+ AC_CHECK_FUNCS(sched_get_priority_max)
+ fi
+ IMUDP_LIBS=$LIBS
+ AC_SUBST(IMUDP_LIBS)
+ LIBS=$save_LIBS
+fi
+
# klog
AC_ARG_ENABLE(klog,