summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-10-06 12:37:24 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-10-06 12:37:24 +0200
commitc0de8c6dc4ec4ac270b0c313ea5a1d2689b44db3 (patch)
tree9fd4350fe04646c002ac9208ebc1c92a8d4f2fbf /configure.ac
parentb5afa1a5be2909ed13f77ef0e0804bab75325198 (diff)
downloadrsyslog-c0de8c6dc4ec4ac270b0c313ea5a1d2689b44db3.tar.gz
rsyslog-c0de8c6dc4ec4ac270b0c313ea5a1d2689b44db3.tar.xz
rsyslog-c0de8c6dc4ec4ac270b0c313ea5a1d2689b44db3.zip
bugfix/imuxsock: did not compile on platforms without SCM_CREDENTIALS
Note: we do rate-limiting by the pid and we obtain the pid via SCM_CREDENTIALS socket options. So this patch effectively disables the (new) ratelimiting capability. In a later patch, I'll see that I can provide a global ratelimiting capability, which could always be used (an alternative may be using the tag, will check this out as well).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7254b99d..0dbe0f5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,11 @@ AC_FUNC_STRERROR_R
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([flock basename alarm clock_gettime gethostbyname gethostname gettimeofday localtime_r memset mkdir regcomp select setid socket strcasecmp strchr strdup strerror strndup strnlen strrchr strstr strtol strtoul uname ttyname_r getline malloc_trim prctl epoll_create epoll_create1 fdatasync])
+# the check below is probably ugly. If someone knows how to do it in a better way, please
+# let me know! -- rgerhards, 2010-10-06
+AC_CHECK_DECL([SCM_CREDENTIALS], [AC_DEFINE(HAVE_SCM_CREDENTIALS, [1], [set define])], [], [#include <sys/types.h>
+#include <sys/socket.h>])
+
# Check for MAXHOSTNAMELEN
AC_MSG_CHECKING(for MAXHOSTNAMELEN)
AC_TRY_COMPILE([