summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-09-30 02:01:10 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-10-04 12:29:56 +0200
commit8e51241a50531dc10d00e54aee00a24fc6760811 (patch)
treea3006b639224047e1b55924746c8727de1d7f1fe /configure.ac
parent2cc5fbd49fdca20cdeb8eb81455bc1baef627a77 (diff)
downloadrsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.tar.gz
rsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.tar.xz
rsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.zip
systemd: install service and socket unit files
This adds a systemd socket and service unit file to the default install if systemd is found or explicitly enabled in ./configure. Patch is against current git v5-devel.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1050981b..16454d00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,16 @@ if test "$enable_unlimited_select" = "yes"; then
fi
+# support for systemd unit files
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
+
+
# debug
AC_ARG_ENABLE(debug,
[AS_HELP_STRING([--enable-debug],[Enable debug mode @<:@default=no@:>@])],