summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDražen Kačar <dave@fly.srk.fer.hr>2011-01-10 12:39:23 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2011-01-10 12:39:23 +0100
commit7742b2182fc017ca4c9fcfe3b26f4c8d68a9bd58 (patch)
tree5105b0ff2a8ea76a0729d57111545e5858124daf /configure.ac
parentc4026ec0f8d843540d01b07f94d4182d7dddb62e (diff)
downloadrsyslog-7742b2182fc017ca4c9fcfe3b26f4c8d68a9bd58.tar.gz
rsyslog-7742b2182fc017ca4c9fcfe3b26f4c8d68a9bd58.tar.xz
rsyslog-7742b2182fc017ca4c9fcfe3b26f4c8d68a9bd58.zip
improved imudp real-time scheduling support & bugfix
The original code had quite some issues, which are fixed by this commit. Also we do more error checking now. Signed-off-by: Rainer Gerhards <rgerhards@adiscon.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22365513..02d7c342 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,6 +269,36 @@ if test "x$enable_pthreads" != "xno"; then
)
fi
+AC_CHECK_FUNCS(
+ [pthread_setschedparam],
+ [
+ rsyslog_have_pthread_setschedparam=yes
+ ],
+ [
+ rsyslog_have_pthread_setschedparam=no
+ ]
+)
+AC_CHECK_HEADERS(
+ [sched.h],
+ [
+ rsyslog_have_sched_h=yes
+ ],
+ [
+ rsyslog_have_sched_h=no
+ ]
+)
+if test "$rsyslog_have_pthread_setschedparam" = "yes" -a "$rsyslog_have_sched_h" = "yes"; then
+ save_LIBS=$LIBS
+ LIBS=
+ AC_SEARCH_LIBS(sched_get_priority_max, rt)
+ if test "x$ac_cv_search" != "xno"; then
+ AC_CHECK_FUNCS(sched_get_priority_max)
+ fi
+ IMUDP_LIBS=$LIBS
+ AC_SUBST(IMUDP_LIBS)
+ LIBS=$save_LIBS
+fi
+
# klog
AC_ARG_ENABLE(klog,