summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-09-09 12:24:22 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-09-09 12:24:22 +0200
commit3cbd7300c47991aadca00db1b028fd3d5d551040 (patch)
tree37e4b9e72e22480b132e9e4425e1994231b2f377 /configure.ac
parent947e5632039d1dd2ef3ae22ac45b17370bbac24d (diff)
downloadrsyslog-3cbd7300c47991aadca00db1b028fd3d5d551040.tar.gz
rsyslog-3cbd7300c47991aadca00db1b028fd3d5d551040.tar.xz
rsyslog-3cbd7300c47991aadca00db1b028fd3d5d551040.zip
added module impstat to emit periodic statistics on rsyslog counters
This is a *very first* and *very rough* and *very featureless* first shot at this functionality. It is assumed that we will enhance the stats system as a by-line while doing other development.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c005a19..c52749c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -792,6 +792,19 @@ AC_ARG_ENABLE(imptcp,
AM_CONDITIONAL(ENABLE_IMPTCP, test x$enable_imptcp = xyes)
+# settings for the pstats input module
+AC_ARG_ENABLE(impstats,
+ [AS_HELP_STRING([--enable-impstats],[periodic statistics module enabled @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_impstats="yes" ;;
+ no) enable_impstats="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-impstats) ;;
+ esac],
+ [enable_impstats=no]
+)
+AM_CONDITIONAL(ENABLE_IMPSTATS, test x$enable_impstats = xyes)
+
+
# settings for the omprog output module
AC_ARG_ENABLE(omprog,
[AS_HELP_STRING([--enable-omprog],[Compiles omprog module @<:@default=no@:>@])],
@@ -1013,6 +1026,7 @@ AC_CONFIG_FILES([Makefile \
plugins/imfile/Makefile \
plugins/imsolaris/Makefile \
plugins/imptcp/Makefile \
+ plugins/impstats/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
plugins/omtesting/Makefile \
@@ -1049,6 +1063,7 @@ echo " plain tcp input module enabled: $enable_imptcp"
echo " imdiag enabled: $enable_imdiag"
echo " file input module enabled: $enable_imfile"
echo " Solaris input module enabled: $enable_imsolaris"
+echo " periodic statistics module enabled: $enable_impstats"
echo " input template module will be compiled: $enable_imtemplate"
echo
echo "---{ output plugins }---"