summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-03-09 08:23:16 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2011-03-09 08:23:16 +0100
commit22f36ffbbd0c4e0fe1bfe331cb7ca15ec6ae80aa (patch)
tree3a2d9f8e4a82352b075a251b5630c0179ea25546 /configure.ac
parent1a0875865300472150c411afa8335e47a1722bae (diff)
downloadrsyslog-22f36ffbbd0c4e0fe1bfe331cb7ca15ec6ae80aa.tar.gz
rsyslog-22f36ffbbd0c4e0fe1bfe331cb7ca15ec6ae80aa.tar.xz
rsyslog-22f36ffbbd0c4e0fe1bfe331cb7ca15ec6ae80aa.zip
testbench: valgrind tests only executed if valgrind is available
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 278288e7..a7d26a1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,10 @@ AC_CONFIG_HEADERS([config.h])
AC_GNU_SOURCE
+# check if valgrind is present
+AC_CHECK_PROG(have_valgrind, [valgrind], [yes])
+AM_CONDITIONAL(HAVE_VALGRIND, test x$have_valgrind = xyes)
+
# check for Java compiler
AC_CHECK_PROG(HAVE_JAVAC, [javac], [yes])
if test x"$HAVE_JAVAC" = x""; then