summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-04-12 15:10:00 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-04-12 15:10:00 +0200
commit7053a438efd07361b6e33de4bdf254b1d3b58553 (patch)
treebd5c83d8141bcd28a0c0a21f447ecdab522ab487 /configure.ac
parent6eeff56d010e48e4e5a7eca41223832edca5c5d1 (diff)
parent4ebd062564c068566d60b4f54c047e6c082edf8e (diff)
downloadrsyslog-7053a438efd07361b6e33de4bdf254b1d3b58553.tar.gz
rsyslog-7053a438efd07361b6e33de4bdf254b1d3b58553.tar.xz
rsyslog-7053a438efd07361b6e33de4bdf254b1d3b58553.zip
Merge branch 'v4-stable' into v4-devel
Conflicts: ChangeLog
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14cb2ee6..a6ac2abc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -632,6 +632,23 @@ AC_ARG_ENABLE(rsyslogd,
AM_CONDITIONAL(ENABLE_RSYSLOGD, test x$enable_rsyslogd = xyes)
+# capability to enable an extended testbench. By default, this is off. The reason
+# for this switch is that some test simply take too long to execute them on a regular
+# basis. So we enable to skip them, while the majority of tests can still be used. The
+# idea is that at least "make distcheck" executes the extended testbench, and also
+# developers should explicitely enable it after important changes. -- rgerhards, 2010-04-12
+AC_ARG_ENABLE(extended_tests,
+ [AS_HELP_STRING([--enable-extended-tests],[extended testbench @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_rsyslogd="yes" ;;
+ no) enable_rsyslogd="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-extended-tests) ;;
+ esac],
+ [enable_extended_tests=no]
+)
+AM_CONDITIONAL(ENABLE_EXTENDED_TESTS, test x$enable_extended_tests = xyes)
+
+
# Mail support (so far we do not need a library, but we need to turn this on and off)
AC_ARG_ENABLE(mail,
[AS_HELP_STRING([--enable-mail],[Enable mail support @<:@default=no@:>@])],
@@ -900,6 +917,7 @@ echo " SNMP support enabled: $enable_snmp"
echo
echo "---{ debugging support }---"
echo " Testbench enabled: $enable_testbench"
+echo " Extended Testbench enabled: $enable_extended_tests"
echo " Debug mode enabled: $enable_debug"
echo " Runtime Instrumentation enabled: $enable_rtinst"
echo " Diagnostic tools enabled: $enable_diagtools"