summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-08-06 17:32:29 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-08-06 17:32:29 +0200
commit40e70777ea9e9d72b87a387ca3fe67ce45c3e00f (patch)
tree88687f796b0efd4c2c61aaca4feb5977933f9f14 /configure.ac
parente4c926bfbca3aab3fe34fc9cfedb7343423de016 (diff)
parent80ff634c841d692c1d9f335b88e225d6ce7317f7 (diff)
downloadrsyslog-40e70777ea9e9d72b87a387ca3fe67ce45c3e00f.tar.gz
rsyslog-40e70777ea9e9d72b87a387ca3fe67ce45c3e00f.tar.xz
rsyslog-40e70777ea9e9d72b87a387ca3fe67ce45c3e00f.zip
Merge branch 'v4-devel'
Conflicts: ChangeLog Makefile.am configure.ac doc/rsyslog_conf_modules.html runtime/rsyslog.h tests/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcfdaf2f..117c08dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -909,6 +909,20 @@ AM_CONDITIONAL(ENABLE_GUI, test x$enable_gui = xyes)
AC_SUBST(RELP_CFLAGS)
AC_SUBST(RELP_LIBS)
+
+# settings for omuxsock
+AC_ARG_ENABLE(omuxsock,
+ [AS_HELP_STRING([--enable-omuxsock],[Compiles stdout module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omuxsock="yes" ;;
+ no) enable_omuxsock="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omuxsock) ;;
+ esac],
+ [enable_omuxsock=no]
+)
+AM_CONDITIONAL(ENABLE_OMUXSOCK, test x$enable_omuxsock = xyes)
+
+
# This provides a vehicle to integrate custom modules, that are not
# part of rsyslog, into the build process. It is named cust1, so that
# additional such modules can easily be added.
@@ -983,6 +997,7 @@ AC_CONFIG_FILES([Makefile \
plugins/pmlastmsg/Makefile \
plugins/omruleset/Makefile \
plugins/omdbalerting/Makefile \
+ plugins/omuxsock/Makefile \
plugins/imfile/Makefile \
plugins/imsolaris/Makefile \
plugins/imrelp/Makefile \
@@ -1029,6 +1044,7 @@ echo " omstdout module will be compiled: $enable_omstdout"
echo " omruleset module will be compiled: $enable_omruleset"
echo " omdbalerting module will be compiled: $enable_omdbalerting"
echo " omudpspoof module will be compiled: $enable_omudpspoof"
+echo " omuxsock module will be compiled: $enable_omuxsock"
echo " output template module will be compiled: $enable_omtemplate"
echo
echo "---{ parser modules }---"