summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-11-17 08:47:30 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-11-17 08:47:30 +0100
commitc9841fbd368e58674cc166e6186b2a29f9895211 (patch)
treeec43ae6d43bcf61d730552532130c8b0ea536cf2 /configure.ac
parent8c29f2843591376f8a1abca5f09a9740927f1000 (diff)
downloadrsyslog-c9841fbd368e58674cc166e6186b2a29f9895211.tar.gz
rsyslog-c9841fbd368e58674cc166e6186b2a29f9895211.tar.xz
rsyslog-c9841fbd368e58674cc166e6186b2a29f9895211.zip
added a skeleton for omdbalerting by request of Phil Reilly
... who intends to add a database-driven alert functionality. The change provides the necessary rsyslog plumbing, but no functionality at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eeb2c2f4..2ce99b94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -805,6 +805,20 @@ AC_ARG_ENABLE(omruleset,
AM_CONDITIONAL(ENABLE_OMRULESET, test x$enable_omruleset = xyes)
+# settings for omdbalerting
+AC_ARG_ENABLE(omdbalerting,
+ [AS_HELP_STRING([--enable-omdbalerting],[Compiles omdbalerting module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omdbalerting="yes" ;;
+ no) enable_omdbalerting="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omdbalerting) ;;
+ esac],
+ [enable_omdbalerting=no]
+)
+AM_CONDITIONAL(ENABLE_OMDBALERTING, test x$enable_omdbalerting = xyes)
+
+
+
# building the GUI (mostly for diagnostic reasons)
AC_ARG_ENABLE(gui,
[AS_HELP_STRING([--enable-gui],[Enable GUI programs @<:@default=no@:>@])],
@@ -896,6 +910,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omprog/Makefile \
plugins/omstdout/Makefile \
plugins/omruleset/Makefile \
+ plugins/omdbalerting/Makefile \
plugins/imfile/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
@@ -937,6 +952,7 @@ echo " Mail support enabled: $enable_mail"
echo " omprog module will be compiled: $enable_omprog"
echo " omstdout module will be compiled: $enable_omstdout"
echo " omruleset module will be compiled: $enable_omruleset"
+echo " omdbalerting module will be compiled: $enable_omdbalerting"
echo " omudpspoof module will be compiled: $enable_omudpspoof"
echo " output template module will be compiled: $enable_omtemplate"
echo