summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-03-09 14:28:30 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2010-03-09 14:28:30 +0100
commitc802afb7e0fc5e2c87af24e12bf63e4a0ba7688c (patch)
tree107991afae384af32c95be306c86f387ea67083b /configure.ac
parent81c9cf86267fb0ec1156e578439d09499c97e80f (diff)
parentde7726cbf0957384cc9261ac47d6bf65906739b5 (diff)
downloadrsyslog-c802afb7e0fc5e2c87af24e12bf63e4a0ba7688c.tar.gz
rsyslog-c802afb7e0fc5e2c87af24e12bf63e4a0ba7688c.tar.xz
rsyslog-c802afb7e0fc5e2c87af24e12bf63e4a0ba7688c.zip
Merge branch 'v5-stable'
Conflicts: ChangeLog configure.ac doc/manual.html doc/property_replacer.html runtime/datetime.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 24e96965..c59895d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,19 +156,12 @@ AC_SUBST(moddirs)
# Large file support
-AC_ARG_ENABLE(largefile,
- [AS_HELP_STRING([--enable-largefile],[Enable large file support @<:@default=yes@:>@])],
- [case "${enableval}" in
- yes) enable_largefile="yes" ;;
- no) enable_largefile="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-largefile) ;;
- esac],
- [enable_largefile="yes"]
-)
-if test "$enable_largefile" = "no"; then
- AC_DEFINE(NOLARGEFILE, 1, [Defined when large file support is disabled.])
-fi
-
+# http://www.gnu.org/software/autoconf/manual/html_node/System-Services.html#index-AC_005fSYS_005fLARGEFILE-1028
+AC_SYS_LARGEFILE
+case "${enable_largefile}" in
+ no) ;;
+ *) enable_largefile="yes" ;;
+esac
# Regular expressions
AC_ARG_ENABLE(regexp,