summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-03-08 14:27:20 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2010-03-08 14:27:20 +0100
commit06387e5592ffb4f7b20ea631f0824ff2cc652c20 (patch)
treedc964b62013bf67dc18c73d3fc1f3a97e931fed0 /configure.ac
parentb4cdb7c997eee95df96321d11d03cf90e4a6caba (diff)
parent0b84d47f7a244c25f63fadcec92d12ebfbe319a4 (diff)
downloadrsyslog-06387e5592ffb4f7b20ea631f0824ff2cc652c20.tar.gz
rsyslog-06387e5592ffb4f7b20ea631f0824ff2cc652c20.tar.xz
rsyslog-06387e5592ffb4f7b20ea631f0824ff2cc652c20.zip
Merge branch 'v4-stable' into beta
Conflicts: ChangeLog configure.ac doc/manual.html tests/rt-init.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index b297b284..e58d2072 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,19 +156,12 @@ AC_SUBST(moddirs)
# Large file support
-AC_ARG_ENABLE(largefile,
- [AS_HELP_STRING([--enable-largefile],[Enable large file support @<:@default=yes@:>@])],
- [case "${enableval}" in
- yes) enable_largefile="yes" ;;
- no) enable_largefile="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-largefile) ;;
- esac],
- [enable_largefile="yes"]
-)
-if test "$enable_largefile" = "no"; then
- AC_DEFINE(NOLARGEFILE, 1, [Defined when large file support is disabled.])
-fi
-
+# http://www.gnu.org/software/autoconf/manual/html_node/System-Services.html#index-AC_005fSYS_005fLARGEFILE-1028
+AC_SYS_LARGEFILE
+case "${enable_largefile}" in
+ no) ;;
+ *) enable_largefile="yes" ;;
+esac
# Regular expressions
AC_ARG_ENABLE(regexp,