summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-07-09 09:42:38 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-07-09 09:42:38 +0200
commitb1d8366b905a956885b5d7ae9a7cb1e23d0ada4d (patch)
treee0ff5698b3966de88ab1bf39493dec5f2f2ab161 /configure.ac
parent3e4aa167eed33a37163446feb2f28efe3e4582d5 (diff)
downloadrsyslog-b1d8366b905a956885b5d7ae9a7cb1e23d0ada4d.tar.gz
rsyslog-b1d8366b905a956885b5d7ae9a7cb1e23d0ada4d.tar.xz
rsyslog-b1d8366b905a956885b5d7ae9a7cb1e23d0ada4d.zip
made udp spoofing code compile (but does not necessarily run right now, untested)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e9cfe073..8eb58df2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,6 +176,28 @@ if test "$enable_regexp" = "yes"; then
fi
+# libnet (for UDP spoofing)
+AC_ARG_ENABLE(libnet,
+ [AS_HELP_STRING([--enable-libnet],[Enable libnet support (for UDP spoofing) @<:@default=yes@:>@])],
+ [case "${enableval}" in
+ yes) enable_libnet="yes" ;;
+ no) enable_libnet="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-libnet) ;;
+ esac],
+ [enable_libnet=yes]
+)
+AM_CONDITIONAL(ENABLE_LIBNET, test x$enable_libnet = xyes)
+if test "$enable_libnet" = "yes"; then
+ AC_CHECK_HEADER(libnet.h, [libnet_header="yes"], [libnet_header="no" enable_libnet="false"])
+ if test "$libnet_header" = "yes"; then
+ AC_CHECK_LIB(net, libnet_init,
+ [AC_DEFINE(USE_LIBNET, 1, [Define if you want to enable libnet support])
+ LIBNET_LIBS="-lnet"
+ AC_SUBST(LIBNET_LIBS)], enable_libnet="false")
+ fi
+fi
+
+
# zlib compression
AC_ARG_ENABLE(zlib,
[AS_HELP_STRING([--enable-zlib],[Enable zlib compression support @<:@default=yes@:>@])],