summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-03-26 15:49:39 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2010-03-26 15:49:39 +0100
commit91a5e176d609d77d4451d7d7b1bf00dfdac5fe50 (patch)
treeea0cf9aa553ca5810ef78afb1bb26131dad2dc6a /configure.ac
parentee6ce30b474c033c71f5f5e9edf7941e29ea30b6 (diff)
downloadrsyslog-91a5e176d609d77d4451d7d7b1bf00dfdac5fe50.tar.gz
rsyslog-91a5e176d609d77d4451d7d7b1bf00dfdac5fe50.tar.xz
rsyslog-91a5e176d609d77d4451d7d7b1bf00dfdac5fe50.zip
added initial files for door support & fixed imklog
imklog now basically works, but needs quite some more work to do
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c24468be..64f4fdc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -715,6 +715,19 @@ AC_ARG_ENABLE(imfile,
AM_CONDITIONAL(ENABLE_IMFILE, test x$enable_imfile = xyes)
+# settings for the door input module (under solaris, thus default off)
+AC_ARG_ENABLE(imdoor,
+ [AS_HELP_STRING([--enable-imdoor],[door input module enabled @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_imdoor="yes" ;;
+ no) enable_imdoor="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-imdoor) ;;
+ esac],
+ [enable_imdoor=no]
+)
+AM_CONDITIONAL(ENABLE_IMDOOR, test x$enable_imdoor = xyes)
+
+
# settings for the omprog output module
AC_ARG_ENABLE(omprog,
[AS_HELP_STRING([--enable-omprog],[Compiles omprog module @<:@default=no@:>@])],
@@ -816,6 +829,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omprog/Makefile \
plugins/omstdout/Makefile \
plugins/imfile/Makefile \
+ plugins/imdoor/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
plugins/omtesting/Makefile \
@@ -847,6 +861,7 @@ echo "---{ input plugins }---"
echo " Klog functionality enabled: $enable_klog ($os_type)"
echo " imdiag enabled: $enable_imdiag"
echo " file input module enabled: $enable_imfile"
+echo " Solaris door input module enabled: $enable_imdoor"
echo " input template module will be compiled: $enable_imtemplate"
echo
echo "---{ output plugins }---"