summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2009-05-18 21:47:59 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-05-19 07:31:22 +0200
commit67974ecd5df103b4d69932410ea0147cba469f9b (patch)
treecae8dc946d09214f0ff1aed35390910235d6cfac /configure.ac
parent460edfe27fcca96e88d6541a3e1ccb49ab4b1a7a (diff)
downloadrsyslog-67974ecd5df103b4d69932410ea0147cba469f9b.tar.gz
rsyslog-67974ecd5df103b4d69932410ea0147cba469f9b.tar.xz
rsyslog-67974ecd5df103b4d69932410ea0147cba469f9b.zip
Rename want_gssapi_krb5 to enable_gssapi_krb5
Be consistent and rename the configure variable want_gssapi_krb5 to enable_gssapi_krb5. Signed-off-by: Rainer Gerhards <rgerhards@adiscon.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9b160379..17c527a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,13 +197,13 @@ fi
AC_ARG_ENABLE(gssapi_krb5,
[AS_HELP_STRING([--enable-gssapi-krb5],[Enable GSSAPI Kerberos 5 support @<:@default=no@:>@])],
[case "${enableval}" in
- yes) want_gssapi_krb5="yes" ;;
- no) want_gssapi_krb5="no" ;;
+ yes) enable_gssapi_krb5="yes" ;;
+ no) enable_gssapi_krb5="no" ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-gssapi-krb5) ;;
esac],
- [want_gssapi_krb5=no]
+ [enable_gssapi_krb5=no]
)
-if test $want_gssapi_krb5 = yes; then
+if test $enable_gssapi_krb5 = yes; then
AC_CHECK_LIB(gssapi_krb5, gss_acquire_cred, [
AC_CHECK_HEADER(gssapi/gssapi.h, [
AC_DEFINE(USE_GSSAPI,,
@@ -213,7 +213,7 @@ if test $want_gssapi_krb5 = yes; then
])
])
fi
-AM_CONDITIONAL(ENABLE_GSSAPI, test x$want_gssapi_krb5 = xyes)
+AM_CONDITIONAL(ENABLE_GSSAPI, test x$enable_gssapi_krb5 = xyes)
# multithreading via pthreads
AC_ARG_ENABLE(pthreads,
@@ -803,7 +803,7 @@ echo "omstdout module will be compiled: $enable_omstdout"
echo "Large file support enabled: $enable_largefile"
echo "Networking support enabled: $enable_inet"
echo "GnuTLS network stream driver enabled: $enable_gnutls"
-echo "Enable GSSAPI Kerberos 5 support: $want_gssapi_krb5"
+echo "Enable GSSAPI Kerberos 5 support: $enable_gssapi_krb5"
echo "Debug mode enabled: $enable_debug"
echo "Runtime Instrumentation enabled: $enable_rtinst"
echo "Diagnostic tools enabled: $enable_diagtools"