summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-04-01 16:31:41 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-04-01 16:31:41 +0200
commit59d4a52c280c00bccde4be0321bb09665cc11d29 (patch)
tree662ee862f9c6bf3fd01f0edb0fe6206e234e1d38 /configure.ac
parente4f012eb60f6531f964557ba9eac54048ae2bef8 (diff)
downloadrsyslog-59d4a52c280c00bccde4be0321bb09665cc11d29.tar.gz
rsyslog-59d4a52c280c00bccde4be0321bb09665cc11d29.tar.xz
rsyslog-59d4a52c280c00bccde4be0321bb09665cc11d29.zip
initial work on omprog, an output module to send messages to another program
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index de328f83..e9e68cb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -668,6 +668,20 @@ AM_CONDITIONAL(ENABLE_IMTEMPLATE, test x$enable_imtemplate = xyes)
# end of copy template - be sure to serach for imtemplate to find everything!
+# settings for the omprog output module
+AC_ARG_ENABLE(omprog,
+ [AS_HELP_STRING([--enable-omprog],[Compiles omprog template module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omprog="yes" ;;
+ no) enable_omprog="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omprog) ;;
+ esac],
+ [enable_omprog=no]
+)
+AM_CONDITIONAL(ENABLE_OMPROG, test x$enable_omprog = xyes)
+# end of omprog
+
+
# settings for the template output module; copy and modify this code
# if you intend to add your own module. Be sure to replace omtemplate
# by the actual name of your module.
@@ -720,6 +734,7 @@ AC_CONFIG_FILES([Makefile \
plugins/imklog/Makefile \
plugins/imtemplate/Makefile \
plugins/omtemplate/Makefile \
+ plugins/omprog/Makefile \
plugins/omstdout/Makefile \
plugins/imfile/Makefile \
plugins/imrelp/Makefile \
@@ -752,6 +767,7 @@ echo "imdiag enabled: $enable_imdiag"
echo "file input module enabled: $enable_imfile"
echo "input template module will be compiled: $enable_imtemplate"
echo "output template module will be compiled: $enable_omtemplate"
+echo "omprog module will be compiled: $enable_omprog"
echo "omstdout module will be compiled: $enable_omstdout"
echo "Large file support enabled: $enable_largefile"
echo "Networking support enabled: $enable_inet"