summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
commitbbfa04fbe63f1bbb47f5cdc683045cf2775b3977 (patch)
tree1321c8edd1daede54d7b9680fc58ebd5cca1ead9 /configure.ac
parent790532bb834e3d4fc07273b2d72127e39ef3e142 (diff)
downloadrsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.gz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.xz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.zip
improved testing support
worked on ways to provide a better test suite: - added -T rsyslogd command line option, enables to specify a directory where to chroot() into on startup. This is NOT a security feature but introduced to support testing. Thus, -T does not make sure chroot() is used in a secure way. (may be removed later) - added omstdout module for testing purposes. Spits out all messages to stdout - no config option, no other features - modified $ModLoad statement so that for modules whom's name starts with a dot, no path is prepended (this enables relative-pathes and should not break any valid current config)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c9483ca..fcd935e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,23 @@ AM_CONDITIONAL(ENABLE_OMTEMPLATE, test x$enable_omtemplate = xyes)
# end of copy template - be sure to serach for omtemplate to find everything!
+# settings for omstdout
+AC_ARG_ENABLE(omstdout,
+ [AS_HELP_STRING([--enable-omstdout],[Compiles stdout template module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omstdout="yes" ;;
+ no) enable_omstdout="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omstdout) ;;
+ esac],
+ [enable_omstdout=no]
+)
+#
+# you may want to do some library checks here - see snmp, mysql, pgsql modules
+# for samples
+#
+AM_CONDITIONAL(ENABLE_OMSTDOUT, test x$enable_omstdout = xyes)
+
+
AC_CONFIG_FILES([Makefile \
runtime/Makefile \
tools/Makefile \
@@ -701,6 +718,7 @@ AC_CONFIG_FILES([Makefile \
plugins/imklog/Makefile \
plugins/imtemplate/Makefile \
plugins/omtemplate/Makefile \
+ plugins/omstdout/Makefile \
plugins/imfile/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
@@ -731,7 +749,8 @@ echo "RELP support enabled: $enable_relp"
echo "imdiag enabled: $enable_imdiag"
echo "file input module enabled: $enable_imfile"
echo "input template module will be compiled: $enable_imtemplate"
-echo "output template module will be compiled: $enable_omtemplate"
+echo "output template module will be compiled: $enable_omtemplate"
+echo "omstdout module will be compiled: $enable_omstdout"
echo "Large file support enabled: $enable_largefile"
echo "Networking support enabled: $enable_inet"
echo "GnuTLS network stream driver enabled: $enable_gnutls"