summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-31 20:06:10 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-31 20:06:10 +0200
commit3b9fd5330a6599c00e9c3c0a4080a141f173aa6a (patch)
treef01a660c1ccf5070101b32a9e7eb75e07c0c6e57 /configure.ac
parent3e3a9bc9982331e44cf397fef131e75553f2ab2c (diff)
parent91d6888a8afe562bf4d2ef53be94c41898e1a2ec (diff)
downloadrsyslog-3b9fd5330a6599c00e9c3c0a4080a141f173aa6a.tar.gz
rsyslog-3b9fd5330a6599c00e9c3c0a4080a141f173aa6a.tar.xz
rsyslog-3b9fd5330a6599c00e9c3c0a4080a141f173aa6a.zip
Merge branch 'master' into sol-test
Conflicts: tests/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7289d74e..2db856cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,23 @@ AM_CONDITIONAL(ENABLE_OMTEMPLATE, test x$enable_omtemplate = xyes)
# end of copy template - be sure to serach for omtemplate to find everything!
+# settings for omstdout
+AC_ARG_ENABLE(omstdout,
+ [AS_HELP_STRING([--enable-omstdout],[Compiles stdout template module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_omstdout="yes" ;;
+ no) enable_omstdout="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-omstdout) ;;
+ esac],
+ [enable_omstdout=no]
+)
+#
+# you may want to do some library checks here - see snmp, mysql, pgsql modules
+# for samples
+#
+AM_CONDITIONAL(ENABLE_OMSTDOUT, test x$enable_omstdout = xyes)
+
+
AC_CONFIG_FILES([Makefile \
runtime/Makefile \
tools/Makefile \
@@ -701,6 +718,7 @@ AC_CONFIG_FILES([Makefile \
plugins/imklog/Makefile \
plugins/imtemplate/Makefile \
plugins/omtemplate/Makefile \
+ plugins/omstdout/Makefile \
plugins/imfile/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
@@ -731,7 +749,8 @@ echo "RELP support enabled: $enable_relp"
echo "imdiag enabled: $enable_imdiag"
echo "file input module enabled: $enable_imfile"
echo "input template module will be compiled: $enable_imtemplate"
-echo "output template module will be compiled: $enable_omtemplate"
+echo "output template module will be compiled: $enable_omtemplate"
+echo "omstdout module will be compiled: $enable_omstdout"
echo "Large file support enabled: $enable_largefile"
echo "Networking support enabled: $enable_inet"
echo "GnuTLS network stream driver enabled: $enable_gnutls"