summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-05 11:10:43 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-05 11:10:43 +0100
commit2e388db9ac91eae35ac836b329c8bcadd319a409 (patch)
tree1ecfb38d83a1cc1d9a6b1d3ad1c4b45fdc0cc755 /configure.ac
parent42db7de5968d2db0fa855a9f029f6bccc0a30650 (diff)
downloadrsyslog-2e388db9ac91eae35ac836b329c8bcadd319a409.tar.gz
rsyslog-2e388db9ac91eae35ac836b329c8bcadd319a409.tar.xz
rsyslog-2e388db9ac91eae35ac836b329c8bcadd319a409.zip
integrated various patches for solaris
Unfortunatley, I do not have the full list of contributors available. The patch set was compiled by Ben Taylor, and I made some further changes to adopt it to the news rsyslog branch. Others provided much of the base work, but I can not find the names of the original authors. If you happen to be one of them, please let me know so that I can give proper credits.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c924754..ff790817 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,13 @@ case "${host}" in
# do not DEFINE OS_BSD
os_type="bsd"
;;
+ *-*-solaris*)
+ os_type="solaris"
+ AC_DEFINE([OS_SOLARIS], [1], [Indicator for a Solaris OS])
+ AC_DEFINE([_POSIX_PTHREAD_SEMANTICS], [1], [Use POSIX pthread semantics])
+ SOL_LIBS="-lsocket -lnsl"
+ AC_SUBST(SOL_LIBS)
+ ;;
esac
AC_DEFINE_UNQUOTED([HOSTENV], "$host", [the host environment, can be queried via a system variable])
@@ -233,7 +240,10 @@ if test "x$enable_pthreads" != "xno"; then
[
AC_DEFINE([USE_PTHREADS], [1], [Multithreading support enabled.])
PTHREADS_LIBS="-lpthread"
- PTHREADS_CFLAGS="-pthread"
+ case "${os_type}" in
+ solaris) PTHREADS_CFLAGS="-pthreads" ;;
+ *) PTHREADS_CFLAGS="-pthread" ;;
+ esac
AC_SUBST(PTHREADS_LIBS)
AC_SUBST(PTHREADS_CFLAGS)
],