summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-07-16 11:57:18 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-07-16 11:57:18 +0200
commit37bac26f6edb2104829ed1b97061753530ecbdf8 (patch)
tree4917f2e3b900914dd7dd47d50cda803aa8e6cf16 /configure.ac
parent6b3bc860f8c47de606d7fa2ae3b51655c2f13838 (diff)
downloadrsyslog-37bac26f6edb2104829ed1b97061753530ecbdf8.tar.gz
rsyslog-37bac26f6edb2104829ed1b97061753530ecbdf8.tar.xz
rsyslog-37bac26f6edb2104829ed1b97061753530ecbdf8.zip
added a samll diagnostic tool to obtain result of gethostname() API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 43888d64..91641416 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,6 +326,19 @@ if test "$enable_valgrind" = "yes"; then
fi
+# compile diagnostic tools (small helpers usually not needed)
+AC_ARG_ENABLE(diagtools,
+ [AS_HELP_STRING([--enable-diagtools],[Enable diagnostic tools @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_diagtools="yes" ;;
+ no) enable_diagtools="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-diagtools) ;;
+ esac],
+ [enable_mail=no]
+)
+AM_CONDITIONAL(ENABLE_DIAGTOOLS, test x$enable_diagtools = xyes)
+
+
# MySQL support
AC_ARG_ENABLE(mysql,
@@ -666,6 +679,7 @@ echo "GnuTLS network stream driver enabled: $enable_gnutls"
echo "Enable GSSAPI Kerberos 5 support: $want_gssapi_krb5"
echo "Debug mode enabled: $enable_debug"
echo "Runtime Instrumentation enabled: $enable_rtinst"
+echo "Diagnostic tools enabled: $enable_diagtools"
echo "valgrind support settings enabled: $enable_valgrind"
echo "rsyslog runtime will be built: $enable_rsyslogrt"
echo "rsyslogd will be built: $enable_rsyslogd"