summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-12-14 11:55:35 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-12-14 11:55:35 +0000
commit0c5e8a2f96dd22534c0b7189ff5e75519be03b82 (patch)
treea96f0e832270068dc3f81d657e4fda76014f4d76 /configure.ac
parent004229dda605fa93fa04f7c94bff69517241a885 (diff)
downloadrsyslog-0c5e8a2f96dd22534c0b7189ff5e75519be03b82.tar.gz
rsyslog-0c5e8a2f96dd22534c0b7189ff5e75519be03b82.tar.xz
rsyslog-0c5e8a2f96dd22534c0b7189ff5e75519be03b82.zip
moved core threading helpers out of syslogd.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64329cfb..ef5353d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -165,6 +165,10 @@ AC_ARG_ENABLE(pthreads,
[enable_pthreads=yes]
)
+if test "x$enable_pthreads" = "xno"; then
+ AC_MSG_ERROR(rsyslog v3 does no longer support single threading mode -- use a previous version for that);
+fi
+
if test "x$enable_pthreads" != "xno"; then
AC_CHECK_HEADERS(
[pthread.h],