summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-11-30 13:43:12 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-11-30 13:43:12 +0000
commit721ca9c56ad1864576757cc06d6b5f058f47285e (patch)
tree79383d1d2f310deca130c34c671b96f1b8970da9 /configure.ac
parent554ee083cfd8d729dd39c87a2b22dcdf4ae1072f (diff)
downloadrsyslog-721ca9c56ad1864576757cc06d6b5f058f47285e.tar.gz
rsyslog-721ca9c56ad1864576757cc06d6b5f058f47285e.tar.xz
rsyslog-721ca9c56ad1864576757cc06d6b5f058f47285e.zip
added compile-time switches for -pthread
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 20fee5c7..90d684dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,8 +164,10 @@ if test "x$enable_pthreads" != "xno"; then
[pthread_create],
[
AC_DEFINE([USE_PTHREADS], [1], [Multithreading support enabled.])
- pthreads_libs="-lpthread"
- AC_SUBST(pthreads_libs)
+ pthreads_libs="-lpthread"
+ pthreads_cflags="-pthread"
+ AC_SUBST(pthreads_libs)
+ AC_SUBST(pthreads_cflags)
],
[AC_MSG_FAILURE([pthread is missing])],
[-lpthread]