summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-12-03 13:53:05 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-12-03 13:53:05 +0000
commit1c3baa7191e5598c9ea082ba2f1d827559909e67 (patch)
treefda07497530c89737a6f5beb836fd8845b7d4029 /configure.ac
parent2b5e4d68ed1e45b3732e53ee382161c8150dddce (diff)
downloadrsyslog-1c3baa7191e5598c9ea082ba2f1d827559909e67.tar.gz
rsyslog-1c3baa7191e5598c9ea082ba2f1d827559909e67.tar.xz
rsyslog-1c3baa7191e5598c9ea082ba2f1d827559909e67.zip
added Bartosz Kuzma patches for better compatibility with NetBSD - many
thanks for them!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b4892f68..12d7d3f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,8 @@ esac
# Checks for libraries.
AC_CHECK_LIB(rt,clock_gettime,,,)
-AC_CHECK_LIB(dl,dlopen,,,)
+AC_CHECK_LIB(dl,dlopen,[have_libdl = yes],[have_libdl = no],)
+AM_CONDITIONAL(HAVE_LIBDL, test x$have_libdl = xyes)
# Checks for header files.
AC_HEADER_RESOLV
@@ -340,14 +341,14 @@ AC_OUTPUT
echo "****************************************************"
echo "rsyslog will be compiled with the following settings:"
echo
-echo "Multithreading support enabled: $enable_pthreads"
-echo "Klogd functionality enabled: $enable_klogd"
-echo "Regular expressions support enabled: $enable_regexp"
+echo "Multithreading support enabled: $enable_pthreads"
+echo "Klogd functionality enabled: $enable_klogd"
+echo "Regular expressions support enabled: $enable_regexp"
echo "Zlib compression support enabled: $enable_zlib"
-echo "MySql support enabled: $enable_mysql"
+echo "MySql support enabled: $enable_mysql"
echo "PostgreSQL support enabled: $enable_pgsql"
-echo "Large file support enabled: $enable_largefile"
-echo "Networking support enabled: $enable_inet"
+echo "Large file support enabled: $enable_largefile"
+echo "Networking support enabled: $enable_inet"
echo "Enable GSSAPI Kerberos 5 support: $want_gssapi_krb5"
-echo "Debug mode enabled: $enable_debug"
+echo "Debug mode enabled: $enable_debug"