summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMilan Bartos <mbartos@redhat.com>2012-09-11 10:10:37 +0200
committerMilan Bartos <mbartos@redhat.com>2012-09-24 08:45:33 +0200
commit6e3980abbdb5d98a66d656456f993374b0be9565 (patch)
tree1ed9c548d84c2c6c41a9a51a9e79a8a4168f07aa /configure.ac
parent4208db41a338c372d8afb8b81ece7c3320334250 (diff)
downloadrsyslog-6e3980abbdb5d98a66d656456f993374b0be9565.tar.gz
rsyslog-6e3980abbdb5d98a66d656456f993374b0be9565.tar.xz
rsyslog-6e3980abbdb5d98a66d656456f993374b0be9565.zip
Added new module, imkmsg, for structured kernel logs from /dev/kmsg.
This is still in development, bute ready to be commited to master. modified: Makefile.am modified: configure.ac new file: plugins/imkmsg/Makefile.am new file: plugins/imkmsg/imkmsg.c new file: plugins/imkmsg/imkmsg.h new file: plugins/imkmsg/kmsg.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58adecb0..e6806f10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,6 +330,18 @@ AM_CONDITIONAL(ENABLE_IMKLOG_BSD, test x$os_type = xbsd)
AM_CONDITIONAL(ENABLE_IMKLOG_LINUX, test x$os_type = xlinux)
AM_CONDITIONAL(ENABLE_IMKLOG_SOLARIS, test x$os_type = xsolaris)
+# kmsg
+AC_ARG_ENABLE(kmsg,
+ [AS_HELP_STRING([--enable-kmsg],[Kmsg structured kernel logs functionality @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_kmsg="yes" ;;
+ no) enable_kmsg="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-kmsg) ;;
+ esac],
+ [enable_kmsg="no"]
+)
+AM_CONDITIONAL(ENABLE_IMKMSG, test x$enable_kmsg = xyes)
+
#
# SYSLOG_UNIXAF
@@ -1358,6 +1370,7 @@ AC_CONFIG_FILES([Makefile \
plugins/imuxsock/Makefile \
plugins/immark/Makefile \
plugins/imklog/Makefile \
+ plugins/imkmsg/Makefile \
plugins/omhdfs/Makefile \
plugins/omprog/Makefile \
plugins/omstdout/Makefile \
@@ -1415,6 +1428,7 @@ echo " Unlimited select() support enabled: $enable_unlimited_select"
echo
echo "---{ input plugins }---"
echo " Klog functionality enabled: $enable_klog ($os_type)"
+echo " /dev/kmsg functionality enabled: $enable_kmsg"
echo " plain tcp input module enabled: $enable_imptcp"
echo " threaded plain tcp input module enabled: $enable_imttcp"
echo " imdiag enabled: $enable_imdiag"