summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Scott <nathans@aconex.com>2011-08-15 22:22:13 +1000
committerRainer Gerhards <rgerhards@adiscon.com>2012-01-17 10:31:37 +0100
commitf8019d52f83884acb5e8f8755fe976d1592b4ccb (patch)
tree58f9362b2f4124489604e2a1f0d263898269b98c /Makefile.am
parent052b1c75945106c6336fd0c172fbaa129248334c (diff)
downloadrsyslog-f8019d52f83884acb5e8f8755fe976d1592b4ccb.tar.gz
rsyslog-f8019d52f83884acb5e8f8755fe976d1592b4ccb.tar.xz
rsyslog-f8019d52f83884acb5e8f8755fe976d1592b4ccb.zip
add elasticsearch output module
Add support for sending events to elasticsearch - a distributed, RESTful, search engine built on Lucene (www.elasticsearch.org). The output module is enabled via a configure option, and uses libcurl to send the messages from rsyslog to elasticsearch. This patch makes use of the earlier JSON quoting patch to ensure valid JSON strings are sent to the server. Signed-off-by: Nathan Scott <nathans@aconex.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index de4777b2..fd348a67 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,6 +168,10 @@ if ENABLE_OMTEMPLATE
SUBDIRS += plugins/omtemplate
endif
+if ENABLE_ELASTICSEARCH
+SUBDIRS += plugins/omelasticsearch
+endif
+
if ENABLE_MMSNMPTRAPD
SUBDIRS += plugins/mmsnmptrapd
endif
@@ -244,5 +248,6 @@ DISTCHECK_CONFIGURE_FLAGS= --enable-gssapi_krb5 \
--enable-imtemplate \
--enable-omtemplate \
--enable-mmsnmptrapd \
+ --enable-elasticsearch \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
ACLOCAL_AMFLAGS = -I m4