summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-09-30 02:01:10 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-10-04 12:29:56 +0200
commit8e51241a50531dc10d00e54aee00a24fc6760811 (patch)
treea3006b639224047e1b55924746c8727de1d7f1fe /Makefile.am
parent2cc5fbd49fdca20cdeb8eb81455bc1baef627a77 (diff)
downloadrsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.tar.gz
rsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.tar.xz
rsyslog-8e51241a50531dc10d00e54aee00a24fc6760811.zip
systemd: install service and socket unit files
This adds a systemd socket and service unit file to the default install if systemd is found or explicitly enabled in ./configure. Patch is against current git v5-devel.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bc6d8dd0..f3dca447 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,25 @@ lmgssutil_la_LDFLAGS = -module -avoid-version
lmgssutil_la_LIBADD = $(GSS_LIBS)
endif
+#
+# systemd support
+#
+if HAVE_SYSTEMD
+
+dist_systemdsystemunit_DATA = \
+ rsyslog.socket
+
+nodist_systemdsystemunit_DATA = \
+ rsyslog.service
+
+CLEANFILES = \
+ rsyslog.service
+
+%.service: %.service.in
+ $(AM_V_GEN)sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+
+endif
+
EXTRA_DIST = \
freebsd/rsyslogd \
slackware/rc.rsyslogd \
@@ -47,7 +66,8 @@ EXTRA_DIST = \
COPYING.LESSER \
contrib/gnutls/ca.pem \
contrib/gnutls/cert.pem \
- contrib/gnutls/key.pem
+ contrib/gnutls/key.pem \
+ rsyslog.service.in
SUBDIRS = doc runtime . plugins/immark plugins/imuxsock plugins/imtcp plugins/imudp plugins/omtesting
@@ -196,5 +216,6 @@ DISTCHECK_CONFIGURE_FLAGS= --enable-gssapi_krb5 \
--enable-shave \
--enable-extended-tests \
--enable-impstats \
- --enable-memcheck
+ --enable-memcheck \
+ --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
ACLOCAL_AMFLAGS = -I m4