summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-10-11 12:53:40 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-10-11 12:53:40 +0000
commit341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5 (patch)
tree749106882fa85e950b0257ac3084ac8c75aabcc2 /Makefile.am
parent6e32d3f1dba30ac353d6bbdd93b7431eef6aa62d (diff)
downloadrsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.tar.gz
rsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.tar.xz
rsyslog-341af8bcd0a7683b6c17ca23f1028ae47a9cf4c5.zip
- changed the build system to use a single source tarball again (but
different makefiles for the main project and ommysql) - applied fixes from Michael Biebl: 1.) fix failing compilation of ommysql plugin (s/ommysql-config.h/config.h/) 2.) fix mysql configure check (although the default is no, we did check for the mysql devel files) 3.) Create a separate Makefile.am for the doc files. This cleans up the toplevel Makefile.am considerably and makes it much more readable and maintainable. 3b) Assign the html doc files to html_DATA. This means, they are installed to $(hmtdir), which by autoconf standards is $(prefix)/share/doc/$packagename/. 4.) Reformat the SOURCES line to make it better readable and maintainable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am85
1 files changed, 77 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b33ce5b..e9373843 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,14 +1,83 @@
-sbin_PROGRAMS=rklogd rfc3195d rsyslogd
+sbin_PROGRAMS = rklogd rfc3195d rsyslogd
-rklogd_SOURCES=klogd.c syslog.c pidfile.c ksym.c ksym_mod.c klogd.h ksyms.h pidfile.h module.h
+rklogd_SOURCES = \
+ klogd.c \
+ klogd.h \
+ syslog.c \
+ pidfile.c \
+ pidfile.h \
+ ksym.c \
+ ksyms.h \
+ ksym_mod.c \
+ module.h
-rfc3195d_SOURCES=rfc3195d.c rsyslog.h
+rfc3195d_SOURCES = rfc3195d.c rsyslog.h
+
+rsyslogd_SOURCES = \
+ syslogd.c \
+ syslogd.h \
+ pidfile.c \
+ pidfile.h \
+ template.c \
+ outchannel.c \
+ stringbuf.c \
+ stringbuf.h \
+ srUtils.c \
+ srUtils.h \
+ parse.c \
+ parse.h \
+ syslogd-types.h \
+ template.h \
+ outchannel.h \
+ liblogging-stub.h \
+ net.c \
+ net.h \
+ msg.c \
+ msg.h \
+ omshell.c \
+ omshell.h \
+ omusrmsg.c \
+ omusrmsg.h \
+ omfwd.c \
+ omfwd.h \
+ tcpsyslog.c \
+ tcpsyslog.h \
+ omfile.c \
+ omfile.h \
+ omdiscard.c \
+ omdiscard.h \
+ modules.c \
+ modules.h \
+ module-template.h \
+ objomsr.c \
+ objomsr.h \
+ cfsysline.c \
+ cfsysline.h \
+ linkedlist.c \
+ linkedlist.h \
+ iminternal.c \
+ iminternal.h \
+ action.c \
+ action.h
+
+rsyslogd_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\"
+rsyslogd_LDADD = $(zlib_libs) $(pthreads_libs) -ldl
+rsyslogd_LDFLAGS = -export-dynamic
man_MANS = rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5
-rsyslogd_SOURCES=syslogd.c pidfile.c template.c outchannel.c stringbuf.c srUtils.c parse.c syslogd-types.h template.h outchannel.h syslogd.h stringbuf.h parse.h srUtils.h liblogging-stub.h net.c net.h msg.c msg.h omshell.c omshell.h omusrmsg.c omusrmsg.h omfwd.c omfwd.h tcpsyslog.c tcpsyslog.h omfile.h omfile.c omdiscard.c omdiscard.h modules.c modules.h module-template.h objomsr.c objomsr.h cfsysline.c cfsysline.h linkedlist.c linkedlist.h iminternal.c iminternal.h action.c action.h
-rsyslogd_CPPFLAGS=-O1 -fmudflapth -D_PATH_MODDIR=\"$(pkglibdir)/\"
-rsyslogd_LDADD=$(zlib_libs) $(pthreads_libs) -ldl -lmudflapth
-rsyslogd_LDFLAGS=-export-dynamic
+EXTRA_DIST = \
+ redhat/rsyslog.conf \
+ redhat/rsyslog.init \
+ redhat/rsyslog.log \
+ redhat/rsyslog.sysconfig \
+ freebsd/rsyslogd \
+ slackware/rc.rsyslogd \
+ contrib/README \
+ $(man_MANS)
+
+SUBDIRS = doc
-EXTRA_DIST = doc/bugs.html doc/features.html doc/generic_design.html doc/history.html doc/how2help.html doc/install.html doc/ipv6.html doc/manual.html doc/property_replacer.html doc/rsyslog_conf.html doc/rsyslog_mysql.html doc/rsyslog_packages.html doc/rsyslog_php_syslog_ng.html doc/rsyslog_recording_pri.html doc/rsyslog_stunnel.html doc/status.html doc/syslog-protocol.html doc/version_naming.html doc/contributors.html redhat/rsyslog.conf redhat/rsyslog.init redhat/rsyslog.log redhat/rsyslog.sysconfig freebsd/rsyslogd slackware/rc.rsyslogd rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5 contrib/README doc/rsconf1_actionexeconlyifpreviousissuspended.html doc/rsconf1_actionresumeinterval.html doc/rsconf1_allowedsender.html doc/rsconf1_controlcharacterescapeprefix.html doc/rsconf1_debugprintcfsyslinehandlerlist.html doc/rsconf1_debugprintmodulelist.html doc/rsconf1_debugprinttemplatelist.html doc/rsconf1_dircreatemode.html doc/rsconf1_dirgroup.html doc/rsconf1_dirowner.html doc/rsconf1_dropmsgswithmaliciousdnsptrrecords.html doc/rsconf1_droptrailinglfonreception.html doc/rsconf1_dynafilecachesize.html doc/rsconf1_escapecontrolcharactersonreceive.html doc/rsconf1_failonchownfailure.html doc/rsconf1_filecreatemode.html doc/rsconf1_filegroup.html doc/rsconf1_fileowner.html doc/rsconf1_includeconfig.html doc/rsconf1_mainmsgqueuesize.html doc/rsconf1_modload.html doc/rsconf1_repeatedmsgreduction.html doc/rsconf1_resetconfigvariables.html doc/rsconf1_umask.html plugins/ommysql/ommysql.tar.gz
+if ENABLE_MYSQL
+SUBDIRS += plugins/ommysql
+endif