summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-07-10 16:12:46 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-07-10 16:12:46 +0000
commit33c28c8d7ada38372fbf7aa414337b4be9377bd8 (patch)
tree4b0f7322c2c8999d01b96abe950bc4080333feb8 /Makefile.am
parentcff4955448a2895a7e1fad8106f5dd1b9a0bfbe7 (diff)
downloadrsyslog-33c28c8d7ada38372fbf7aa414337b4be9377bd8.tar.gz
rsyslog-33c28c8d7ada38372fbf7aa414337b4be9377bd8.tar.xz
rsyslog-33c28c8d7ada38372fbf7aa414337b4be9377bd8.zip
upgrading to autotools build system - thank Peter Vrabec for patches and
the idea
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..ba0f70e3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,11 @@
+
+bin_PROGRAMS=klogd rfc3195d syslogd
+
+klogd_SOURCES=klogd.c syslog.c pidfile.c ksym.c
+
+rfc3195d_SOURCES=rfc3195d.c
+
+syslogd_SOURCES=syslogd.c pidfile.c template.c outchannel.c stringbuf.c srUtils.c parse.c
+syslogd_CPPFLAGS=$(mysql_includes)
+syslogd_LDADD=$(mysql_libs) $(zlib_libs) $(pthreads_libs)
+