summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-08-10 14:51:43 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-08-10 14:51:43 +0200
commit55256ac96815d6e13fc9df7206d50ef7dcaca4fe (patch)
treeb2a6a8be01f33f53c12f937aefc88173b581a952 /Makefile.am
parent318adf58de35d7b8c6ca891b93c351220628586b (diff)
downloadrsyslog-55256ac96815d6e13fc9df7206d50ef7dcaca4fe.tar.gz
rsyslog-55256ac96815d6e13fc9df7206d50ef7dcaca4fe.tar.xz
rsyslog-55256ac96815d6e13fc9df7206d50ef7dcaca4fe.zip
added imptcp
imptcp is a simplified, Linux-specific and potentielly fast syslog plain tcp input plugin (NOT supporting TLS!)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f5f9a6ed..439cb417 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,6 +103,10 @@ if ENABLE_IMFILE
SUBDIRS += plugins/imfile
endif
+if ENABLE_IMPTCP
+SUBDIRS += plugins/imptcp
+endif
+
if ENABLE_IMDIAG
SUBDIRS += plugins/imdiag
endif
@@ -134,5 +138,6 @@ SUBDIRS += tests
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout --enable-omprog --enable-imdiag --enable-shave --enable-extended-tests
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout --enable-omprog --enable-imdiag --enable-shave --enable-extended-tests \
+ --enable-imptcp
ACLOCAL_AMFLAGS = -I m4