summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-16 15:27:53 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-16 15:27:53 +0200
commitd9b0c77d3e719d4c08361e62f3b067228c30f6a9 (patch)
tree20318332f281d64c74d6b0767a24c996a3737901 /Makefile.am
parent91661455ebf63275a849dc5c7f49c21d7837b442 (diff)
downloadrsyslog-d9b0c77d3e719d4c08361e62f3b067228c30f6a9.tar.gz
rsyslog-d9b0c77d3e719d4c08361e62f3b067228c30f6a9.tar.xz
rsyslog-d9b0c77d3e719d4c08361e62f3b067228c30f6a9.zip
some more cleanup
reduced dependencies, moved non-runtime files to its own directory except for some whom's status is unclear
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 4 insertions, 47 deletions
diff --git a/Makefile.am b/Makefile.am
index 123030ce..ef2a0baa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,52 +1,5 @@
sbin_PROGRAMS =
man_MANS =
-
-if ENABLE_RSYSLOGD
-sbin_PROGRAMS += rsyslogd
-rsyslogd_SOURCES = \
- syslogd.c \
- syslogd.h \
- omshell.c \
- omshell.h \
- omusrmsg.c \
- omusrmsg.h \
- omfwd.c \
- omfwd.h \
- omfile.c \
- omfile.h \
- omdiscard.c \
- omdiscard.h \
- iminternal.c \
- iminternal.h \
- pidfile.c \
- pidfile.h \
- \
- action.c \
- action.h \
- threads.c \
- threads.h \
- \
- parse.c \
- parse.h \
- \
- outchannel.c \
- outchannel.h \
- template.c \
- template.h \
- conf.c \
- conf.h \
- cfsysline.c \
- cfsysline.h
-
-rsyslogd_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
-rsyslogd_LDADD = $(zlib_libs) $(pthreads_libs) $(dl_libs) $(rt_libs) $(rsrt_libs)
-rsyslogd_LDFLAGS = -export-dynamic
-
-man_MANS += rsyslogd.8 rsyslog.conf.5
-
-endif # if ENABLE_RSYSLOGD
-
-# now come the library plugins
pkglib_LTLIBRARIES =
if ENABLE_RFC3195
@@ -111,6 +64,10 @@ SUBDIRS = doc runtime .
SUBDIRS += plugins/immark plugins/imuxsock plugins/imtcp plugins/imudp plugins/omtesting
+if ENABLE_RSYSLOGD
+SUBDIRS += tools
+endif
+
if ENABLE_IMKLOG
SUBDIRS += plugins/imklog
endif