summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
commitbbfa04fbe63f1bbb47f5cdc683045cf2775b3977 (patch)
tree1321c8edd1daede54d7b9680fc58ebd5cca1ead9 /Makefile.am
parent790532bb834e3d4fc07273b2d72127e39ef3e142 (diff)
downloadrsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.gz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.xz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.zip
improved testing support
worked on ways to provide a better test suite: - added -T rsyslogd command line option, enables to specify a directory where to chroot() into on startup. This is NOT a security feature but introduced to support testing. Thus, -T does not make sure chroot() is used in a secure way. (may be removed later) - added omstdout module for testing purposes. Spits out all messages to stdout - no config option, no other features - modified $ModLoad statement so that for modules whom's name starts with a dot, no path is prepended (this enables relative-pathes and should not break any valid current config)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 87e378ee..97f4aed3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,3 @@
-AUTOMAKE_OPTIONS=dejagnu
-
sbin_PROGRAMS =
pkglib_LTLIBRARIES =
@@ -90,6 +88,10 @@ if ENABLE_IMTEMPLATE
SUBDIRS += plugins/imtemplate
endif
+if ENABLE_OMSTDOUT
+SUBDIRS += plugins/omstdout
+endif
+
if ENABLE_OMTEMPLATE
SUBDIRS += plugins/omtemplate
endif
@@ -120,5 +122,5 @@ SUBDIRS += tests
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-omstdout
ACLOCAL_AMFLAGS = -I m4