summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuis Fernando Muñoz Mejías <Luis.Fernando.Munoz.Mejias@cern.ch>2009-03-25 18:16:25 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-25 18:48:36 +0100
commitb8f10ad00853275045180738b91e90a80c7693cc (patch)
tree5e1a50b3f6b1e3b4ad64a4e28dc45837e40c7d11 /Makefile.am
parent97480eafbc67ec7e84497868a1777ce0d7881e6c (diff)
downloadrsyslog-b8f10ad00853275045180738b91e90a80c7693cc.tar.gz
rsyslog-b8f10ad00853275045180738b91e90a80c7693cc.tar.xz
rsyslog-b8f10ad00853275045180738b91e90a80c7693cc.zip
Include omoracle in the build system.
Add configure option to build the oracle support, named --enable-oracle and fix the Makefile.am accordingly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 87e378ee..a5c3e267 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -110,15 +110,20 @@ if ENABLE_RFC3195
SUBDIRS += plugins/im3195
endif
+if ENABLE_ORACLE
+SUBDIRS += plugins/omoracle
+endif
+
# tests are added as last element, because tests may need different
# modules that need to be generated first
SUBDIRS += tests
+
# make sure "make distcheck" tries to build all modules. This means that
# a developer must always have an environment where every supporting library
# is available. If that is not the case, the respective configure option may
# temporarily be removed below. The intent behind forcing everthing to compile
# in a make distcheck is so that we detect code that accidently was not updated
# when some global update happened.
-DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-omtemplate --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls --enable-oracle
ACLOCAL_AMFLAGS = -I m4