summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-16 10:26:54 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-16 10:26:54 +0200
commit8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc (patch)
tree8bd92ca19ae3cccd5b160c717960db88bb095e73 /Makefile.am
parent3af28bbd2dc4c79b242aad3b9e3f45cffe0f19d0 (diff)
downloadrsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.tar.gz
rsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.tar.xz
rsyslog-8f8f65abb66d1a7839c30c2d1b4b4d653a8990cc.zip
moved files to the runtime
there are still some files left which could go into the runtime, but I think we will delete most of them once we are done with the full modularization.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 20 insertions, 43 deletions
diff --git a/Makefile.am b/Makefile.am
index a4d1ea5b..5829ff86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,66 +4,43 @@ man_MANS =
if ENABLE_RSYSLOGD
sbin_PROGRAMS += rsyslogd
rsyslogd_SOURCES = \
- datetime.c \
- datetime.h \
- errmsg.c \
- errmsg.h \
syslogd.c \
syslogd.h \
- debug.c \
- debug.h \
- glbl.h \
- pidfile.c \
- pidfile.h \
- template.c \
- outchannel.c \
- stringbuf.c \
- stringbuf.h \
- srUtils.c \
- srUtils.h \
- parse.c \
- parse.h \
- syslogd-types.h \
- template.h \
- outchannel.h \
- liblogging-stub.h \
- threads.c \
- threads.h \
- obj.c \
- obj.h \
- obj-types.h \
- msg.c \
- msg.h \
- conf.c \
- conf.h \
omshell.c \
omshell.h \
omusrmsg.c \
omusrmsg.h \
omfwd.c \
omfwd.h \
- tcpsyslog.c \
- tcpsyslog.h \
omfile.c \
omfile.h \
omdiscard.c \
omdiscard.h \
- modules.c \
- modules.h \
- module-template.h \
- objomsr.c \
- objomsr.h \
- cfsysline.c \
- cfsysline.h \
- linkedlist.c \
- linkedlist.h \
iminternal.c \
iminternal.h \
+ pidfile.c \
+ pidfile.h \
+ \
action.c \
action.h \
- atomic.h
+ threads.c \
+ threads.h \
+ \
+ parse.c \
+ parse.h \
+ \
+ outchannel.c \
+ outchannel.h \
+ template.c \
+ template.h \
+ conf.c \
+ conf.h \
+ tcpsyslog.c \
+ tcpsyslog.h \
+ cfsysline.c \
+ cfsysline.h
-rsyslogd_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" $(pthreads_cflags) $(rsrt_cflags)
+rsyslogd_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
rsyslogd_LDADD = $(zlib_libs) $(pthreads_libs) $(dl_libs) $(rt_libs) $(rsrt_libs)
rsyslogd_LDFLAGS = -export-dynamic