summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-11-18 12:05:51 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2008-11-18 12:05:51 +0100
commit599133164d93afb0dab792dadb8f5d6bc3d68a3f (patch)
tree9a8f791fa21386d3620fb8297e14e1c5eb231a62 /Makefile.am
parenta5417f16044d7d56dbceeea09e25ba3e8c47cc01 (diff)
parent49dcad849e93551d90cd6298a576b67c4ad0c7ef (diff)
downloadrsyslog-599133164d93afb0dab792dadb8f5d6bc3d68a3f.tar.gz
rsyslog-599133164d93afb0dab792dadb8f5d6bc3d68a3f.tar.xz
rsyslog-599133164d93afb0dab792dadb8f5d6bc3d68a3f.zip
Merge branch 'beta'
Conflicts: ChangeLog configure.ac doc/manual.html doc/property_replacer.html
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a3a6e19b..96c9f7d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,3 +107,11 @@ endif
# tests are added as last element, because tests may need different
# modules that need to be generated first
SUBDIRS += tests
+
+# make sure "make distcheck" tries to build all modules. This means that
+# a developer must always have an environment where every supporting library
+# is available. If that is not the case, the respective configure option may
+# temporarily be removed below. The intent behind forcing everthing to compile
+# in a make distcheck is so that we detect code that accidently was not updated
+# when some global update happened.
+DISTCHECK_CONFIGURE_FLAGS=--enable-gssapi_krb5 --enable-imfile --enable-snmp --enable-pgsql --enable-libdbi --enable-mysql --enable-imtemplate --enable-relp --enable-rsyslogd --enable-mail --enable-klog --enable-diagtools --enable-gnutls